Afaria 7 Self Service Portal – Error 403 Forbidden

Let the world know ...Tweet about this on TwitterShare on Google+0Share on Facebook0Email this to someoneShare on LinkedIn0

I came recently across a strange error while trying to access my SAP Afaria 7 self-service portal. Suddenly I got a 403 error message.

The server was down for a few days as I did not have to use it. Maybe the shutdown of my VM didn`t work or Microsoft installed some patches, or something else. In the end, I could not log in anymore at my self-service portal at https://afaria.tobias.de/EUSSP/

I took a look at the site configuration at IIS Admin and the connection string to the AD looked good.

I reinstalled the self-service component, but no luck, still 403. Then I decided to take a closer look at the web site configuration. In IIS, there are ASP app pools, maybe something was wrong. Google pointed my to take a look at the ISAPI and CGI Restrictions located at the root of the web server.

The ASP.NET for 64 bit was not allowed to be used (restriction).

I activated that one. Afterwards, all are allowed (32bit and 64 bit, for all version)

To be on the safe side, I also run aspnet_regiis.exe –I from the installation directory of .NET v4 64bit.

Command: aspnet_regiis.exe –I

Now I was able to log on to SAP Afaria Self-Service Portal again!

 

Let the world know ...Tweet about this on TwitterShare on Google+0Share on Facebook0Email this to someoneShare on LinkedIn0

Leave a Reply

Your email address will not be published. Required fields are marked *